Unable to launch 2.1 beta

When trying to launch the game, at the title screen the load bar gets to about 60% and stops. Let it sit for some 30 minutes and it never moved on.

If you are using mods disable them.If not try verifying your files.

Did have mods, but removed.
tried to verify, still would not launch.
Tried to reinstall as well, same.

Same happens to me,
The beta was working fine when i had it on my large but slow drive, so I decided to delete local storage trough steam, and then reinstall it on my ssd drive. now it loads to 60% ish and then just stops…So my initial thoughts is that the uninstaller dont remove all ?? and when reinstalled it is linked to some wrong files? any Ideas?

I cannot say for certain. I am not using an SSD.

However, for me after I had deleted and reinstalled everything, I forgot a mods folder and that was causing my issue. If you have a mods folder, might try backing it up somewhere then deleting the mods folder.

I saw someone else solve game wouldnt launch because they had it on an external ssd.