Ubuntu 18.04 Gog version - Crash with Doomspider

Hi,

While playing and going to the Bald Hilltop for the first time (quest-wise) in chapter 1, in the fight as soon as I hover Doomspider with turn-mod, I crash. If I uninstall turn-mod, I crash when it spawns.

I tried five times, 3 with turn based & other mods, twice with only CloserToTableTop. What seems to be common in Player.log before the crash is the following :

Unloading 12 Unused Serialized files (Serialized files now loaded: 141)

Unloading 2127 unused Assets to reduce memory usage. Loaded Objects now: 536190.
Total: 1737.663000 ms (FindLiveObjects: 80.112000 ms CreateObjectMapping: 70.930000 ms MarkObjects: 1555.537000 ms DeleteObjects: 31.084000 ms)

Await event system
Await input module
Look rotation viewing vector is zero
Look rotation viewing vector is zero
Receiving unhandled NULL exception
#0 0x007f053cb25c40 in funlockfile
#1 0x007ffe047fb9a0 in (Unknown)
#2 0x007ffe047fb9b0 in (Unknown)
#3 0x007ffe047fb9c0 in (Unknown)

Also testing in Window mod didn’t help.

Something that seems slightly close would be : https://github.com/pardeike/Harmony/issues/198 (since it’s C# related)

And googling “pathfinder kingmaker doomspider crash” doesn’t help.

Any help would be appreciated,
Thank you

Have you try to simply just verify the integrity of the game files?
https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

Also, you should check if you have any GPU driver update.

I’m using Gog version and therefore can’t verify integrity the way Steam allows. Also I’m not using a SSD.

I just updated my video card driver and I doubt that would solve a unit spawning / attacking crashing the game.

(I can simply not attack it but it will crash when it attacks me)

Just right click on the game in the GOG launcher, you should see a option call verify/repair try that.

There is no GoG Launcher. I did reinstall overwriting all files though. No change.

EDIT : We can miss attack on Doomspider (I was using skeleton, autoattack) which doesn’t crash. Passing by and having it AoO me crashed.

Game really crashes when either hovering or when Doomspider attacks.

RE-EDIT : https://forum.unity.com/threads/unity-game-server-crash-in-physx-funlockfile-on-ubuntu.527466/ has a similar “#0 0x007f0af10a9400 in funlockfile” error.

RE-RE-EDIT : I started playing around with options, and I was able to get the fight done. However I tried to isolate the problem and couldn’t (I thought it might be related to pausing, or one of the game option, really weird). Reloading retriggers the error, I’m not constantly having it run smooth (though doing nothing simply crashes). I believe it’s something related to toying with options and having the cursor on no unit for a few Doomspider attacks, then I can hover it.

A very similar bug happens when doing the quest “Investigate My Death” when meeting the elves; fight starts and crash occurs in the fight.