PC randomly shuts down

Platform: Windows 10 Steam and GOG

Do you have any mods?
No

Please explain the issue is in as much detail as possible:

I got a new PC and I have the problem that the gaem randomly shuts down the System.
There is no Bluescreen or error code.
In the windows evntlog is is only that the system was shut down but no reason.

I normally play via steam but out of desperation I tested the Gog version, same problem.
I even fomtated my PC and installed Windows fresh on it.

The shutdown seems random, sometimes in battle and sometimes on the map.
For a test I left it running while being in a dialog in the throne room, after 10 minutes or so the PC shuted down again.

I can play more performance heavy games without a problem on max settings (Warhammer total war - CPU or Doom Eternal - GPU for example), I don’t know what it could be.

Can someone maybe help me?

Thanks in advance!

1 Like

Verify the integrity of the game files first
https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

Do you have a overclocked CPU?

Hey,

yes I did that.
It said no problems found, I also did sfc /scannow and changed the compatibility to Windows 7.
I am not overclocking my CPU.

First, what hardware do you have?
And the typical questions, though you’ve probably checked that: did you update your BIOS and your drivers?

Maybe you can tune the graphics options all the way down and see if that makes any difference. Is your system getting hot? Normally it’s not a demanding game, a few times I even forgot it was still running in the background.

Does it turn down whole computer?
If yes I guess it could be overheating.

  1. Really powerful systems go into hundreds of FPS and game tries to use all of them so it uses extra resources and that generates additional heat, limit it to 60 FPS.
  2. Dusty hardware - probably not it, since you can run more demanding games, but it can be both of these points working together.

Hey,

thanks for the reply!
I got in contact with the GOG Support, right now I am two hours into playing without any problems.
Hope this is really the solution.^^

In case someone other the same issue, here the step the support told me (Can’t put all the liunks here since I am a new user):

  1. Please add Galaxy folders:
    C:\Program Files (x86)\GOG Galaxy
    to your security software exceptions list. If the game is installed outside of GALAXY folder, then please add game’s installation folder to security software exceptions list as well. Once above is done, please select the game in GOG GALAXY , click on the customize button (to the right of Play)-> Manage Installation → Verify/Repair.

  2. Reinstall the June 2010 DirectX runtime package. You can find the archive file containing the 2010 package installation files here:
    Download DirectX End-User Runtimes (June 2010) from Official Microsoft Download Center

You will have to extract the files into some folder, then open that folder and launch the DXSETUP.exe file in order to proceed with the installation.

After that please download and install DirectX Web Installer:
https://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=35

Please have in mind that this will only add DirectX 9.0c to available pool of DirectX libraries, and it will not overwrite your other versions. Some games are not able to utilize newer DirectX libraries, and they require DirectX 9.0c.

  1. Please update your graphics device drivers

  2. Please set a more standard refresh rate (60 Hz). To do this right-click an empty space on your desktop, select Display Settings > Advanced Display Settings > Monitor tab > change the Screen refresh rate to 60 Hertz.

  3. Please navigate to the game installation folder:

  • If the game was installed via GALAXY, please select the game in GALAXY, click on Customize (to the right to the ‘play’ button) → Manage Installation → Show Folder

  • If the game was installed via offline installer, then you will have to manually navigate to the game installation folder, by default it’s: C:\GOG Games\game-title\

Once in there find game’s “Launch” shortcut, right-click on it, and select Properties. In properties window switch to Compatibility tab, and here enable “Disable full screen optimization”, as well as “Run as administrator”. Press Ok to apply settings. Right-click on the game’s “Launch” shortcut and select “Run as administrator”.

2 Likes