My WotR kickstarter badge is missing and I can't vote in the pools

Sorry to post this here, but I’ve tried emailing team@owlcatgames.com and nothing has been fixed yet.

My backerkit is active and I’ve added my forum nickname, but I still have no badge nor can I vote in the pools.

Thank you in advance.

Yeah I have the same Problem, when did you add your Badge? It will probably take some time, give it a few days or so, the poll will be runing a month.

A few days? Oh! I though it would have been an automated thing :smiley:

I did it yesterday :slight_smile:

Yeah I have the same problem, I wrote an email and not sure if they didn’t read it or I didn’t got the answer and tried to DM a mod here and nothing.

Ah… it takes days.
I assumed it was an automated thing!

Oh yeah, I’m having the same problem.

If you haven’t done so already, either send a message via Kickstarter to Owlcat, email them at team@owlcatgames.com, or private message Mortheim (if you have the functionality, a button to message should show up on the top right of this page: https://forum.owlcatgames.com/u/mortheim/summary). Then be prepared to wait a few days as this seems to be a rather widespread issue.