Linux version broken after update 2.1.7 (I think Linux got mixed up with Windows when shipping)

Platform: Linux PC

Do you have any mods? No

Please explain the issue is in as much detail as possible:

The game does is looking for my user data in the wrong place. If the portraits folder is anything to go by, it’s looking for it as if I was on Windows. That is to say C:\user\username\AppData\LocalLow\Owlcat Games\Pathfinder\Kingmaker\Portraits instead of /home/username/.config/unity3d/Owlcat Games/Pathfinder Kingmaker/Portraits.

The next thing I did was uninstall the game, and completely remove ~/.config/unity3d/Owlcat Games/Pathfinder Kingmaker, ~/.local/share/Steam/userdata/steamuserID/640820, as well as the game directory, then redownload the game. I also disabled all DLC… just because.

That didn’t help.

What I did next has nothing to do with my attempts to get this working. I was deduping the data and noticed that where there should be a “Linux” directory there is instead a “Windows” directory. Also, there is a Rewired_Windows.dll file that isn’t present in the previous Linux version. So I think the Windows and Linux builds got mixed up.

edit: Fortunately, I’m anal retentive about data retention so I have a copy of 2.1.5d (which is what I was dedupping the new version against), so I’ll just use that for now, though I really did appreciate that fix to changing action type in turnbased.

Hello krovoc,

Thank you for the report. We are expecting a fix very soon to deal with this issue.

Hi! Do you have Kingmaker in Steam?

Have you tried installing Windows version via Wine recently?

Yes, I purchased and run it from Steam.

I have tried running the Windows version with Proton. It has it’s own set of issues, but it isn’t completely broken.

To keep mod support and for people experiencing issues with the new version, we have added the previous version of the game (2.1.5d) to the Steam Beta interface.

To activate it, right-click your game in the Steam library, click PROPERTIES → BETAS and select to opt-in for version 2.1.5d.


We checked linux version we uploaded, and it’s the right one. Your situations looks like you could have some files left from installing Windows version. Maybe you still have something left from that time you tried to run Windows version?

My procecure including completely deleting everything in all known relevant paths.

~/.local/share/Steam/steamapps/common/Pathfinder Kingmaker
~/.config/unity3d/Owlcat Games/Pathfinder Kingmaker

Though I didn’t delete the data, the paths themselves were non-existent. I either renamed them by appending a “.bu” to them or by leaving a version in a snapshot (which Steam shouldn’t have access to).

I just now updated from a working installation of 2.1.5d of the Linux version. I’m not sure why, but it works now.

Thank you for looking into this.

I have a different problem, but I think it belongs in this thread. Sorry if necro’ing.

Installed the game in may, newest version, non-beta. Kingdom Management is bugged, slows down and eventually crashes the game. I noticed that steam usually crashes just prior to PKM.

My syslog informs me, repeatedly, that there’s an error in Specifically it states that it can’t be preloaded (wrong ELF class). Do you realize how hard it is to google a solution for this when it’s an RPG? Either way, it appears the Linux version is referencing the wrong executable, though I’m not sure if it’s 32/64-bit related or it was mixed up with the windows version as this thread claims.

It’s fascinating that it only manifest in the kingdom management UI, and that it pulls the entire steam client with it. Perhaps Valve is responsible for this one.

I’ve downgraded to the beta version to see if it persists. It’s not really a solution though.

Btw I run Manjaro Gnome, the native steam client and no mods.

Is you use Wayland or X? If Wayland, try X next time.


However, I suspect the problem originates from a steam update, or maybe it’s my system. Usually I can figure it out myself, but it’s absolutely impossible to gather meaningful search results for “wrong ELF class” for an RPG.

I could of course just run it through proton and see what happens, but when there’s an actual Linux version I prefer using that, assisting in further development. And in this case it’s an isolated yet major bug, since it only applies to the kingdom management overlay. Perhaps during loading screens as well, either way it should be easy to replicate.