Game locks up during character creation

Steam, all DLC, Win 10 64 Bit, AMD 1800X, 64 GB RAM, C Drive is 8TB SSD and I run Steam on it/load games from it.

The first time or two I loaded the game I just ended up with a black screen before anything but the credits. After a reboot I managed to get to the settings, with it set to windowed mode. I’ve a 4k monitor. Ultimately I got into the start. Chose the easier difficulty and got into character creation rather than taking a pregen. But it just stopped accepting mouse clicks after awhile.

I could switch between several portraits before locking up. Or if I chose one, I could go farther and flip some aspects of a character before nothing would move, though often I’d still get audio feedback as if the engine were still responding.

Sometimes I could CTRL-ALT-DEL to Task Manager or ALT-TAB to quit the program but a couple of times I just had to reset my PC.

Quite troublesome.

Well I’m not the most tech savy person but here are some recommendations. I used to get an issue where my screen would black out but audio still played (on a few games it would happen) and to solve that I would go to amd catalyst (or the nvidia one if you use an nvidia card) and up the power going into the card (just little by little though). I had always heard (though it could be something else) that when the screen goes black and you still hear sound it’s because there isn’t enough power going into the card so it doesn’t display on the monitor. Also check your drivers, and verify your files in Steam. While you run the game turn on the performance monitor that gives you the info on card temp, power, and other info to see if maybe it’s overheating or some of the numbers fluctuate too much or something. Hopefully there is some useful info here for you, if not hopefully someone more tech savy can help you out.

I can get same results IF I overclock my GPU (graphic card) too much and use settings what are OK for short tests but in bit longer run get too hot and reset result GPU settings (while screen go “black”).

  • First if you have overclocked your CPU / RAM / GPU try to turn them in default settings and check if it help.

  • So it can be that your GPU is overheating. If you drop your game resolution 1080p and set your graphic settings as low as possible will you still encounter same problems?

  • Try to open your PC’s side case and increase air flow (maybe using some table fan next to open case). Do that help?

My video card is a 1080 TI with 11GB of DDR5, I’ve never felt the need to overclock. Now overheating was an interesting idea. I watercool my CPU, but my GPU is aircooled - and close to the case (a glass window.). Even with the fan cranked up the temps got up around 132 degrees f, and that was just into the character gen. I cranked the fans up to near max and opened the case and they dropped below 100 quickly, but that didn’t keep it from locking up. Tried again with no better luck, though the temps were more reasonable.

I did see an interesting new window I couldn’t get to while ALT-TABing though, it was labeled Pathfinder Kingmaker Unity, with a pretty long code or index after that and a big blank white box with a checkmark and a green loading bar at the bottom that looked only about 20% done. I don’t know what to make of that, but I’m pretty sure it’s a new phenomena. At least I didn’t notice it earlier.

I tried running with a pre-gen, but had no better luck. Quite frustrating. I think I’d enjoy the game if it’d just run.

Try to run the game as a admin.

Interesting suggestion. I tried it outside of the Steam launcher and it loaded fine. I got farther in character creation than ever before. But it still locked up during assignment of stats. I didn’t get any sign of that extra window I’d seen earlier though.

I’ve seen others mention that Unity window too, though I checked things they said and I certainly don’t have a Citrix driver on my system, I’d have been willing to uninstall it had it been there.

This is pretty goofy. My temps were good though. About 91-92 f. If only it worked. ;(

Have you already try to?

  • Update your graphic card driver.
  • Set graphic option display mode to borderless window

They are the most common fix or issues with the game.

My driver was just updated before I first loaded the game. I first ran it on borderless window.

I did find a suggestion on Steam that allowed me to get through character creation and play for a good while. I had leave my machine for a while and just left the game running on the world map. Upon return I discovered it locked up… again. But it was fun while it lasted. We’ll see when it autosaved I guess.

The fix was to go to nvidia control panel (not geforce experience “Adjust desktop size and position”.

In the scaling tab you see “Select a scaling mode:” and 3 radio buttons.
The bottom radio button is “No scaling”

Selecting that did the trick apparently.