Game crashes when I try to claim the outskirts

I’ve tried like a dozen times! But I just can’t expand my kingdom at all. There appears to be some sort of “territory filling in” map animation, and then the game freezes and exits immediately afterwards.

I’m playing on Mac. Has anyone else had this error? Does anyone know a work-around? (maybe editing the save or something, I dunno, I’m getting desperate since I’ve seen nothing about this bug anywhere). I’m worried it will keep me from progressing the game further.

Text of error is as follows:

I’m experiencing the same problem (game version 1.1.5), also on a Mac.

This is happening 100% of the time to me too. I’m unable to progress past this point in the game, which is really terrible since at this point I’m pretty hooked :frowning:

I’ve found a number of other reports of this on the web, e.g. here: https://steamcommunity.com/app/640820/discussions/0/1730963192537633130/

(note that the URL given there for submitting a bug report doesn’t work any longer)

A workaround of running the binary with -force-gfx-metal is often suggested, but this doesn’t help for me. I also don’t know why it would, since the stack trace shows that the game is already using metal.

From reading some apple documentation, this crash seems to be because the game is requesting a particular anti-aliasing mode that is only supported on some Mac hardware (in my case I’m running on a “MacBook Pro (Retina, 13-inch, Mid 2014”), see e.g.

https://developer.apple.com/documentation/metal/mtltexturedescriptor/1516260-samplecount

Other sampleCount modes like 1 and 4 are supported on “all devices”. I tried changing the anti-aliasing graphics setting to “4x” (was “disabled” for me) but this didn’t help.