Game crashes house at the edge of time - Save file needed if possible

Hi, so I’ve been playing the game for hours without a single crash and now that I am at the house at the edge of time, the game keeps crashing when I try to reach a companion. It just freezes but I still get sound.

I uninstalled the game, restarted the pc, reinstalled the game, changed the resolution and graphics settings to the lowest and on windowed mode, but it still crashes. No error message. Have to task manager and end the process.
Tried loading from an older save and it happened again.
I've experienced this when trying to get linzi, jathal and tristian and kanera. For some miraculous reason I have been able to get ekun, valerie, octavia, regongar and that's it.

try to verify the integrity of the game files. https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

And also make sure graphic option display mode is set to borderless window.

Any mods, character edits, etc? That sounds like the moment that the game checks all of the variables that describe the decisions that you made throughout the game.

Luckily they trim down the save file just as you get there, so that is potentially an option.