Freeze on melee attack

I’m playing the Steam version of Pathfinder: Kingmaker on Linux.

After gaining the barony, the game completely freezes whenever either my main character or Valerie attacks using a melee weapon. This does not happen for other characters and did not occur in the previous chapters either. I went back to an earlier save when it worked and had the same problems after getting the barony.

I also tried out Beneath The Stolen Lands and didn’t have any issues there either.

My system:

Arch Linux
Kernel 5.6.15-arch1-1
Intel i7-4700MQ
NVIDIA Quadro K1100M
16GB Ram

I’m using the following mods:

Bag Of Tricks
Camera Rotation
Closer to Tabletop
UI Extensions
Turn Based Combat

Turning them off does not help. My drivers are up to date, I run the game in Exclusive Fullscreen and tried Borderless Window and already verified the game file integrity using steam.

Here’s the GameLogFull.txt:
https://pastebin.com/zfkep2ze

And here’s the Player.log:
https://pastebin.com/3NWQ3Tt3

I’m not sure about Linux but on Windows the most common reason this could happen and/or fix is

  • Exclusive fullscreen is a bugged setting, change it for borderless window.
  • Check if you can update your graphic card driver.
  • Verify the integrity of the game files

Since you already try those, then i will think it’s because of mods that might have corrupted your game in some way. But this it’s just a guess…

Try different things, like unequipping their shield if they have one, use or unuse different abilities (power attack, Expertise, etc.)/weapon/armours/equipment.
If it always happens after gaining the Barony, try making different choices when gaining it, all of this to try and narrow down the problem.
Also try different graphic settings.
I know you have done a lot of things already, but it seems there were problems linked to all of these on some configurations.
Like this, for instance : https://www.reddit.com/r/Pathfinder_Kingmaker/comments/9zz9cy/two_characters_wont_use_any_incombat_actions/
It’s not the same problem, but it might be related.

Unequipping them and turning off abilities does not help.
I started a new game and went through it quickly with cheats to see if maybe something got corrupted during my original playthrough, but I have the same problem.

Hmm, I had no such issues and was also playing on linux.

What is the current setting on that?

And what ‘cheats’ are you using?

Currently on Borderless Window.

I installed the Bag of Tricks mod after first having this problem to load an earlier save and quickly get back to where I was (so the problem persisted before that.)
I used party invulnerability and one hit kills to speed up the process.