Ekundayo join bug makes me cry, halp plz! :(

Ne never joins and the dialog just loops. :frowning:
Is there any fix for this?
Videolink: Here

Try to verify the integrity of the game files.
https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

Are you using any mods and if yes, which ones?

Ty for the reply,
No, no mods, clean install from steam and verification say alll is as it should be.

Do you have the main quest Troll trouble?

Oh… at 0:28 sec, chose ‘‘follow me’’.

Edit: well, actually it’s the same…

Ye, Tried it aswell and with the same result,
As for the quest, i managed to totally miss him before i did the quest, as mentioned in the dialogue aswell. :confused:

Also, make sure you don’t overwrite any of your auto saves, but go to the world map and check if he is in the reserve.

So that mean the troll king is dead?

He is not, first thing i tried was to go back to the city and see if he were there.
Yes, the King was killed.

Normally he can only be recruited during troll trouble and before the troll king is dead. I have never ‘‘miss’’ him so i don’t personally know if this is the regular conversation after the death of the troll, but it look like it.

Unfortunately, he cannot be recruited anymore :frowning:

The current dialogue he has seems to be designed for him joining after the quest is done though. Cant help to feel this is something that needs fixin, it just feels like 40 hours of pure regret right now. :sleepy: :sleepy:

Anyways Ty for help, even though we coulndt find a solution :slight_smile:

1 Like

Yes Ekundayo and Jubilost are to easy to miss on a first playthrough…