Beta 2.1 Bug List

Beta 2.1 Bug List

  • Kinetic Knight is extremly bugged. Character often will not attack.
  • (FIXED) Endless dungeon mode: Resting in the starting area via the table does not work.
  • Kinetic Knight is missing his/her “Burn” display
  • Valleries dialogue in the tutorial seems to be missing after traversing the burning room.

Kingdom management buttons do nothing.

If your pc or npc runs out of movement after casting a touch spell on TB. The ai gets confused and does nothing. Switching back to rtwp fixes sometimes. With linzi and cure light wounds it crashes sometimes.

  • When creating a new character or mercenary it can be the case that no race is preselected leading to a weired 3D character preview.

I found a bandit body in the kitchen in the tutorial with a +1 axe and a note indicating that the body should have been at the Lone Watchtower zone.

Retraining appears to only refund some scrolls(probably only as high as you can cast). Retraining also does not reset your picture.

Entering the inn inside of Oleg’s Trading Post has crashed me 2 out of the last three times this message:
"Error: You are releasing a path which is not claimed at all (most likely it has been pooled already). Are you releasing the path with the same object (_navigation (Kingmaker.TurnBasedMode.Pathfinding.SeekerWithClearance)) twice?

Check the documentation on path pooling for help.
at Pathfinding.Path.Release (System.Object o, System.boolean silent) [0x00082] in <6a7cc84e136848f0bfebd2d3d4e429f1>:0

https://imgur.com/PkMRgvl is a screenshot of the error I get once I crash back to main menu.

I’m at Oleg’s trading post, I’ve completed the first few quests (next up is to visit the Temple of the Elk), I have every possible party member at this point, no custom party members, I’ve completed Bokken’s sidequests. Both times I’ve crashed have been after selling stuff to Oleg. I crash when I try to transition into the actual building to go rest, I don’t see a loading screen I just crash to main menu.

FWIW I am really enjoying replaying this! I can’t put my finger on any specific thing but it feels like the whole game is smoother and combat feels a lot better. Turn Based works really nicely except for a couple of hiccups that other people have mentioned, and it is really nice to be able to easily pop in and out of it.

edit: PM me if you want me to grab a bug report or whatever, I can’t predict if I will crash but I can keep grabbing a report and then entering the trading post until I get one that crashes me.

  • Sage Sourcerer can not progress past level 9 because the player is unable to pick a “New Arcana” Talent …

  • Kinetic Knight in Turn based mode is bugged beyond believe and the longer you play the more bugged it gets, especially if you use gather power. If you release him in this way I will find you and kick you in the but!

Fencing grace allows bucklers in the other hand but slashing grace does not. Either way suits me Owlcats but can you change them to match? Camilla has rapier and buckler skill for free as well. I understand that wealth has extra access but 2 feats seems a bit much.

  • While the Kinetic Knight feels a bit better in the latest patch, it is still bugged in turn based mode. Problem: when executing an attack with the kinetic blade and the target is more than one movemant action away, the kinetic knight does not run to the target and stop before it, it only moves a few steps and all actions are spent.
  • cannot pick loot from varhnoldt stockade chests using keyboard UI. switching to controller allows to pick the loot, but the items appear invisible (despite the container showing N items and looting working)
  • cannot split team in two during season of bloom, plugging controller allows selection
  • cannot enter valley of death without jaethal present during varhnold vanishing, despite it having nothing to do with her quest yet

Don’t know if it is a bug or intended design, but I think it’s annoying, that the mouse camera-movement is kinda locked during turn-based fights (and yes - I’m aware of the two camera options) - it would be nice if there would be a 3rd option to make the mouse camera-movement during fights unlockable or to unlock it by default. Thanks.

When starting a fight (in turn-based mode) with a “Charge” the char often starts to run towards the foe, but at some point before reaching the foe the char gets stuck for a few secs (while the ‘run’ animation is still playing-hence it looks like the character is running but isn’t really moving) before resuming/finishing the charge.

Can’t build a village in the Outskirts after claiming the area. Never had a problem until now with that (IE seems to be since beta only).

*Tried building the village with it’s regular name on multiple town spots available.
*Tried building the village with a renamed village in multiple spots.
*Tried reloading and doing both of the above.
*Tried doing the same from the save before that one where I had not been into the throne room in a few days - same results.

It allows the click on ‘build’ but reverts immediately back to the village location selection screen, without taking BP.

2.1.0g

Do not dismiss or kill Jaethal,

Valley of the dead is bugged at the moment and require Jaethal to enter during the Varnhold Vanishing.